Installera och optimera en ny SSD-hårddisk på rätt sätt

Reviderad 2011-12-15

De sista åren har det blivit allt populärare att skaffa en SSD-disk. Inte så konstigt med tanke på hur snabba dessa är jämfört med en vanlig mekanisk hårddisk. Men tyvärr så är nätet fullt med en massa tips om hur man bör optimera sitt system för en SSD och många av dessa är antingen utdaterade och gäller inte för nyare operativsystem, mest tänkta för att spara plats om man skaffat en för liten SSD eller helt enkelt felaktiga.

Så, vad skall man göra egentligen?

Installation av Windows 7 på en ny och tom SSD:

  1. Kontrollera att AHCI är tillslagen i ert moderkorts BIOS för den SATA-kontroller som disken är ansluten till.
  2. Anslut endast SSD-disken och koppla bort eventuellt extra hårddiskar eller äldre systemdisk (detta för att undvika att Windows installerar sin lilla dolda bootpartition på fel disk eller uppdaterar en befintlig på gamla disken). Koppla den till ert moderkorts bästa/primära SATA-kontroller och undvik de extra kontrollers som en del kort har. Intels eller AMDs egna kontroller är till exempel att föredra framför Marvell osv.
  3. Kontrollera om det finns nyare Firmware till er SSD och uppdatera den som jag skrev om här. Vilken firmware som disken levereras med brukar stå på dess etikett. Det kan även vara bra att kolla moderkortets BIOS och eventuellt uppdatera, ofta fixas stabilitetsproblem som kan påverka just SATA. Men är ni osäker så hoppa hellre över och uppdatera senare om ni får problem.
  4. Se till att använda Windows 7 eller nyare för att få stöd för TRIM. TRIM behövs för att hålla en SSD fräsch, annars tappar den prestanda efter hand.
  5. Sätt i Windows 7-skivan, starta upp och installera som vanligt (kan eventuellt behöva kolla i bios så den är ställd att boota ifrån DVD-läsaren). Man behöver inte skapa någon partition utan det sköter installationen automatiskt med optimal alignment för en SSD.
  6. Installera alla nödvändiga drivrutiner, börja alltid med drivaren till ert moderkorts Chipset (till exempel Intels INF Update Utility). Efter det grafikkort, ljudkort, osv.
  7. När alla drivrutiner är installerade så kör Prestandaklassificering (Windows Experience Index) för att mäta prestandan på datorn och den nya disken. Detta är viktigt eftersom Windows 7 sen anpassar sin cachehantering efter hur snabb hårddisken är. Alla nyare SSD är så pass snabba att Windows 7 kommer automatiskt att slå ifrån exempelvis Superfetch efter att systemet körts ett tag.
  8. Till sist så anslut eventuellt extra hårddiskar igen. Observera att Windows 7 kommer automatiskt att utesluta SSDn ifrån den schemalagda defragmenteringen. Extra mekaniska hårddiskar kommer dock fortfarande att defragmenteras. Man skall ALDRIG defragmentera en SSD!
  9. KLART!

Det är allt man behöver göra.

-

Testa er SSDs prestanda:

Efter installation så ladda gärna hem något testprogram för att se om er SSD ger förväntad prestanda. Ett program som är speciellt anpassat för att testa just SSD utan att slita onödigt mycket är AS SSD Benchmark.

Ett exempel med en Intel 320 160GB:

Observera de båda raderna med grön text märkta OK! Den första visar att disken använder Windows 7:s AHCI-drivrutin – msahci (eller iastor om ni kör med Intel RST) och den andra att partitionens alignment är optimerad för SSD. Är någon av dessa istället märkta med BAD så bör det åtgärdas.

Sandforce-baserade SSD använder komprimering av data för att få högre hastighet, men AS-SSD mäter med data som inte går att komprimera. Därför får man ”sämsta möjliga” resultat när man mäter med detta program. Vill ni veta den teoretiska maxfart som dessa diskar kan ge så använd i stället programmet ATTO som ni laddar hem här. Vid praktisk användning av en SSD som kör med komprimering kommer alltså hastigheten att röra sig nånstans emellan de resultat man får med AS-SSD och ATTO beroende på hur mycket just den filen går att komprimera.

VARNING: Det är lätt att man frestas att göra en mängd olika prestandatester på sin nya SSD, undvik det! Dels så kan en del testprogram skriva enorma mängder data till disken som leder till onödigt slitage (det är främst skrivning som sliter på en SSD) och sen så kan en del SSD tillfälligt dra ner på sin prestanda om det skrivs abnormt mycket till den under kort tid. Så låt disken vara ifred efter att ni konstaterat att allt är ok!

-

Bonus optimeringar & tips:
Nedan några extra tips som inte är nödvändiga att göra men som kan ge en lite extra prestanda eller utrymme.

  • Har ert moderkort ett chipset ifrån Intel så kan ni få lite extra prestanda genom att installera Intels egna SATA-drivrutin – Intel® Rapid Storage Technology. Windows 7s egna AHCI-drivrutin är snabb och stödjer TRIM som standard så det är inte nödvändigt men RST kan som sagt ge lite bättre prestanda.
  • Har ni valt en liten SSD och vill att Windows skall ta så liten plats som möjligt så välj att avaktivera Hibernation som jag skrev om här. Ni kan även rensa bort eventuell backup ifrån Service Pack.
  • Det kan även vara idé att slå ifrån Indexeringstjänsten som jag skrev om här. Den gör kanske inte så stor skada på en SSD men använder man inte sökfunktionen så ofta i Windows så tycker jag det är bättre att ha indexeringen frånslagen. Sökningar funkar ändå men tar bara lite längre tid (betydligt mindre tid på en SSD jämfört med mekanisk hårddisk).
  • För ägare av en SSD ifrån Intel så kan det vara intressant att ladda hem Intel® Solid State Drive Toolbox. Det programmet hjälper en att kolla så systemet är optimerat för SSD, ger en information om dess hälsa via SMART samt låter en manuellt köra TRIM-optimering (TRIM körs även automatiskt hela tiden med Windows 7).

-

Saker man ABSOLUT INTE skall göra:

  • Ett tips som man tyvärr ofta ser påstår att man bör flytta Windows växlingsfil – pagefile till en mekanisk hårddisk för att undvika slitage på en SSD. Detta är helt vansinne och är det sista man skall göra! Växlingsfilen bör man alltid ha på snabbaste disken med så låg accesstid som möjligt och det slitage den eventuellt medför är inget att oroa sig över. Dock kan man experimentera med att ställa ner storleken till något fast värde om man har mycket internminne installerat, men låt den vara på SSDn!
About these ads
Det här inlägget postades i Dator och har märkts med etiketterna , , , , , , , , . Bokmärk permalänken.

50 kommentarer till Installera och optimera en ny SSD-hårddisk på rätt sätt

  1. Danne skriver:

    Halloj Bengan!

    Var ett tag sen ju!
    Tänkte just skaffa en ny SSD så det här var intressant.
    Tror det får bli en Intel som din för de där jävla Sandforce diskarna blir man ju bara less på, BSOD o frysningar o skit. Har provat en Corsair Force3 och en GT, samma elendä med båda trots ny firmware.

    Har du uppdaterat till nya firmware på din 320 och funkade det bra?

    • benganrocks skriver:

      Tjena Danne!

      Jodå, jag uppdaterade min 320 för några dagar sen, funkade fint. Väldigt enkelt att göra faktiskt och all data på disken finns kvar så bara att köra vidare.

      Är faktiskt väldigt nöjd med min 320, har inte varit några problem alls och den är snabb så det räcker. Tyvärr verkar många se sig blinda på den sekventiella topphastigheten i tester men för en systemdisk så är ju random läs/skriv av mindre filer och låg accesstid betydligt viktigare. Samt att disken är stabil…

  2. AlcoN skriver:

    Hejsan. Ska installera win7 på min nya ihop plockade dator. Har Asus M4A88TD-M amd processor och tänkte sätta windowset på en ssd 64gb. Min fråga är att är det viktigt att hårdisken sitter på en specifik sata kontakt på moderkortet av dom 6 möjliga som finns på kortet, och måste jag gå in i Biosen direkt vid första uppstart för att aktivera AHCI och sen installera windowset för att på bästa möjliga resultat? Är inte något dataproffs men lär mig mer och mer ;) Är första gången jag kör operativsystem på en SSD h:disk och vill få det rätt från början.
    Tacksam för svar :)
    Alcon

    • benganrocks skriver:

      Hej!

      Det brukar vara enklast att sätta systemdisken på huvudkontrollerns första port (oftast döpt antingen SATA 0 eller 1). Då kommer bios att lägga den först i bootordningen. Ordningen går alltid att ställa i efterhand i bios men blir ändå enklare så tycker jag. Rent prestandamässigt så tror jag inte det har så stor betydelse längre även om de flesta rekommenderar att man använder första porten.

      Ja, du bör ha AHCI tillslagen direkt innan du installerar Windows. Det går att slå till även efteråt genom pillande i Windows register som jag skrev om tidigare på bloggen men vid nyinstallation så bör man helt klart ha det tillslaget.

      En annan sak att tänka på innan installation är att kolla på SSD-tillverkarens hemsida om det finns nyare Firmware. Då är det lika bra att uppdatera det med innan man installerar windows. Tyvärr har många av de nyare diskarna haft barnsjukdomar som man då förhoppningsvis fixat genom ny firmware.

      Lycka till! :)

  3. jim skriver:

    Nä nu blev jag ledsen i ögat du hade ju en mycket bättre disk än mig 320 160gb än mig =(
    jag som har nyinstallerat och nyaste bioset och allt

    • benganrocks skriver:

      Tror inte du behöver vara så ledsen :)

      Tänk på att värdena kan variera rätt mycket från test till test och även resten av systemet påverkar, som moderkort, sata-kontroller, OS, hur mycket tjänster som är till i bakgrunden osv.

      De gånger jag testat min så har den nog pendlat i värden nånstans emellan ditt resultat och mitt ovan. Ditt värde för 4K tycker jag möjligen är lite lågt men å andra sidan så är ditt 4K-64 högre än för min disk.

      Prova att starta om maskinen och låt den vara ifred en 10 minuter så alla tjänster efter uppstart kört klart. Slå sen ifrån ditt antivirus och testa igen.

      Man kan även köra en manuell TRIM via Intels toolbox innan testet så disken är så fräsch som möjligt. Men har man Windows 7 så bör det ju egentligen skötas automatiskt och inte behövas.

      Den score som AS SSD ger kan man i princip strunta i (möjligt att algoritmen för den ändras mellan versioner av programmet med), det är mer prestandasiffrorna som är intressant.

  4. nik skriver:

    hej! men hur gör jag om jag inte vill installera om alla program. går det att klona alla program från befintlig disk till tom ssd för att sedan ha ssd som systemdisk?

    • benganrocks skriver:

      Jo, det skall funka så länge din gamla systempartition inte tar större plats än din nya SSD. Det finns ett antal verktyg för att klona partitioner med, Intel har en gratis för oss som kör med deras SSD här: http://www.intel.com/support/go/ssdinstallation/

      MEN, oavsett vilket verktyg du använder så kolla så SSDn sedan får rätt alignment! Det kan man kolla med AS-SSD som jag skrev om ovan. Visas alignment som BAD så får man kraftigt försämrad prestanda och bör fixa det med exempelvis Paragon Alignment Tool.

  5. benganrocks skriver:

    Lade nu till punkten 3 om att uppdatera SSDns firmware och moderkortets BIOS.

  6. Felix Medersten skriver:

    halloj, riktigt bra tråd, har lärt mig otroligt mkt tänkte bara kolla me dig om en sak då angående min prestanda !

    jag har 2 st ssd corsair force 3 240 gb som jag kör raid 0 me.

    här är testresultatet i det program du rekomendera.

    read write
    seq 422.76 mb/s 209.05 mb/s
    4k 20.25 67.14
    4k-64thrd 298.04 237.65
    acc.time 0.231 ms 0.295 ms

    361 326
    866

    är det bra ? för 2 ssd i raid 0 ? hela datorn är sprillans allt som allt i burkväg ca 30k

    tack för svar ! mvh felix

    • benganrocks skriver:

      Hmm, jag har aldrig brytt mig om att köra SSD i raid så vågar egentligen inte svara på det. Beror mycket på vilken raid-kontroller man använder med.

      Men ditt 4k-64thrd värde ser trevligt ut när många småfiler skall laddas samtidigt.

      • Felix Medersten skriver:

        Godmorgon, oki jag förstår inte riktigt jag heller, var många år sisst jag byggde mig en datorn, har inte riktigt satt mig in i alla dessa nya och snabbbare komponenter.

        Datorn byggdes försig av en enda anledning. BF3

  7. Elvenman skriver:

    Hej! Jag såg att du lämnade en del bra tips på min tråd i Sweclockers forum. Min nuvarande systemdisk partition är på 150gb och är fylld till ca. 60 gb. Kan jag då klona den disken till min Intel 320 Series 120 gb utan problem?
    Vad är alignment förresten? Har ingen större koll på det där. :)

    • benganrocks skriver:

      Ja, de bra program för kloning som finns idag skall stödja att man minskar ner partitionen vid kopieringen under förutsättning att den data som finns på den får plats. Intels migrerings verktyg tex. är ju en gratis version av Acronis som skall vara bra. Man skall bara se till att välja Manuella läget och inte Automatiska när man börjar så kan man sen justera storleken på partitionen. Kolla den pdf-manual som man kan ladda ner på Intels sida.

      Alignment kan man nog skriva en längre uppsats om så det orkar jag inte och kan antagligen inte förklara det särskilt bra heller…
      Men för att en SSD skall funka optimalt så måste data sparas i lika stora ”klumpar” som SSDns minnesceller är uppdelade i, vilket för de flesta innebär en klusterstorlek på 4 kilobyte (4096 bytes). Därför är det viktigt att partitionerna startar på ett ställe på disken så att de kommer i ”synk” med dess fysiska celler. Alignment offset i AS-SSD ovan visar var partitionen börjar nånstans i KB och skall då vara delbart med 4 för att data skall hamna optimalt.

      Är alignment felaktig så kommer varje kluster att skrivas till två celler istället för en = sämre prestanda och disken slits fortare.

      Begriper knappt själv vad jag skrev så slutar nog där. ;)

  8. Lars skriver:

    Hej! När du nämner Windows 7-skivan vid installation, så utgår jag ifrån att du menar en ren Windows 7-skiva som du köpt ifrån någon databutik.

    För dom som inte har någon sådan skiva utan bara återställningsskivor (t ex köpt märkesbärbar dator) som man själv skapar när man fick sin nya dator. Hur gör man då? Söker lite varstans… men tycker det nämns mycket kloning och det är jag helst inte intresserad av.

    Kan man ändå ta bort HDD fysiskt från datorn (där du har oftast en recoverypartition någonstans i disken) och försöka installera recoverydiskarna direkt på SSD? Fungerar det som en vanlig ren Windows 7-skiva då?

    • benganrocks skriver:

      Ja, det bör funka. SSD fungerar ju egentligen på precis samma vis som en vanlig mekanisk hårddisk.

      Men tänk på att dessa recoverydiskar oftast också är en form av klon. Så din dator kommer antagligen att bli återställd till det skick den var vid leverans med de program som då var installerade. Ett alternativ är ju då att skapa nya recoverydiskar efter hur datorn ser ut just nu. Du kan då även använda Windows egna program för detta som jag skrev om här: http://bengansblogg.wordpress.com/2011/09/06/windows-7-skapa-en-systemavbildning-spegling-av-systemdisken/

      I vilket fall så kolla upp efteråt så att SSDns alignment blivit rätt genom att köra exempelvis AS-SSD ovan. Ofta när man klonar ifrån en mekanisk hårddisk så kan alignment bli felaktig och man får fixa det med Paragon Alignment Tool.

      En fördel med att ta bort din gamla systemdisk först är ju att skulle det inte fungera så kan du ju alltid sätta tillbaks den och köra på som innan tills man hittar en lösning.

  9. hemslöjd skriver:

    Har installerat w7 64 på ett MSI X58A-GD65baserat system med en Corsair SSD som disk för operativsystemet. Inga problem, funkar perfekt. Då jag ansluter fler satadiskar startar inte windows. Har kollat, och alla diskar syns i bios, har provat ”disable” som bootalternativ för dessa, och kollat att bootordningen är korrekt. Datorn stannar efter bios-sekvensen, då windows ska ta över.

    Enda sättet att få upp extra hårddiskar är att starta dem efter att windows är uppe. Har provat foematera en disk i detta läge och starta om, men tyvärr….

    Något tips i denna kunniga skara?

    • benganrocks skriver:

      Vilken Sata-kontroller använder du för SSDn? Det moderkortet har ju dels Intels egna Sata-II (port 1-6) och sedan en påbyggd Marvell Sata-III (port 7-8) som tyvärr ofta leder till problem. Oftast blir det stabilare att helt slå ifrån Marvell-kontrollern och nöja sig med Intels Sata-II, man får ändå inte full hastighet ifrån Marvell. Enklast att koppla SSDn till port 1 för att den skall bootas först utan att ändra i bios.

      Annars är det ju som vanligt senaste BIOS till moderkortet och senaste Firmware till SSDn som gäller men det har du kanske redan provat.

      Syns det något felmeddelande när datorn stannar?

      • hemslöjd skriver:

        Tack för svaret.
        Bios och övriga drivrutiner är uppdaterade. Ja, sata3portarna har Marvels controler, och det är där SSDn sitter. Jag har provat att sätta SSDn i en sata2port, men då stannar den också, på samma sätt. Inga felmeddelanden visas.

        SSDn står i IDEläge, slår jag över till ahci stannar det också, men då med felmeddelande om saknat bootdevice.

  10. benganrocks skriver:

    hemslöjd >
    Slog du då även ifrån Marvell-kontrollern helt i bios så dess rom inte laddas? Det kan eventuellt ha betydelse.

    Installerade du Windows 7 med SSDn i AHCI-läge? Annars måste du följa guiden här för att slå till det utan fel vid uppstart: http://bengansblogg.wordpress.com/2010/11/25/sla-till-ahci-mode-for-er-sata-disk-efter-windows-7-installerats/

    Observera också att när man ändrar mellan IDE/AHCI i bios så kan bootordningen behöva ställas om igen.

    • hemslöjd skriver:

      Hej
      Nu har jag testat.
      Stängde av Marvell-kontrollern i bios men fick ingen uppstart på annan satakanal.
      W7 installerades med SSDn i IDEläge. Jag har aktiverat ahci i registret. Om jag ställer om till ahci i bios startar den inte. Bootordningen kallar disken för Bootdevice 1: IDE:S0 även om ahci är tillsalget och sparat i Bios.

      Marvell-kontrollern är 88SE9128. I bios har den drivrutin 1.0.0.1027.
      Efter uppstart driver 1.0.0.1042 den.

      Men någon fler disk klarar den inte av starta med.

      • benganrocks skriver:

        Knepigt problem det där!
        Jag skulle nog prova med att börja om från början. Rensa CMOS på moderkortet, ladda standardinställningar i bios så alla enheter upptäcks igen osv. Slå helt av Marvel-kontrollern och se till att Intels kontroller är ställd i AHCI från början. Koppla SSDn till Intels första port. Installera sen Windows igen och välj att blåsa gamla installationen. När allt är klart så anslut övriga diskar.

        Funkar det fortfarande inte och det tidigare funkat med vanliga diskar så verkar ju SSDn ha problem.

        Ingen kul lösning men det är väl allt jag kan komma på.

      • hemslöjd skriver:

        Klurigt värre…. den har aldrig funkat med andra diskar, eftersom hela maskinen är ny.

      • hemslöjd skriver:

        Nu gjorde såhär:
        Rensade allt SATAanslutet. Kopplade SSDn på Sata 1 och startade maskinen, och se den gick igång. (Noterade att windows gjorde ”installera maskinvara på SSDn”) Däremot går den inte igång i achi-läget. Moderkortet ställer det läget i raidkontroller: IDE, RAID eller ACHI. Endast IDE funkar. Hängde på optiska enheterna sist, kanal 5 och 6 och den startade igen. Kopplade en hårddisk på kanal två och den rackaren startade en gång till. Allt detta med Marvell inaktiverad.

        Aktiverade Marvell och kopplade SSDn dit istället. Fungerade! Inte i ahci trots att värdena i registret är korrekta. Men den funkar i alla fall i IDE med arbetsdiskar anslutna nu.

        Tusen tack för bollplankeri.
        Antar att vid (eventuell) ominstallation kan det vara idé att installera i achi-läge och sedan presentera SSDn för operativsystemet via satakanal 1.

  11. johan skriver:

    Hej!

    När jag ska starta datorn med enbart ssd som ja installerad win7 på står de please select a proper boot device etc.. sen startas datorn om o allt fungerar som vanligt..

    Asjobbiigt med de 5sek extra att starta datorn bara, hur fixar jag detta :(? Har bara en ssd i kopplad!

    • benganrocks skriver:

      Det här kan ju bero på lite allt möjligt så man måste nog veta lite mer om din hårdvara för att ringa in felet. Eftersom du bara har SSDn inkopplad så antar jag att du inte hade några andra diskar inkopplade heller när du installerade windows? Då kan vi åtminstone utesluta att boot-filerna finns på fel disk.

      Några saker att prova:

      – Har du senaste Firmware på SSDn? En del SSD med Sanforce-kontrollers har haft problem med att moderkortets bios ibland ”tappar bort” dem och då kan man få just det här fenomenet. Kolla på tillverkarens hemsida om det finns nyare firmware. Kan eventuellt löna sig att uppdatera moderkortets bios med.

      – Prova att gå in i bios och kolla så att SSDn är först i bootordningen.

      – Dubbelkolla vilken SATA-kontroller och ingång disken är kopplad till. Det är alltid bäst att ha den kopplad till huvudkontrollern på moderkortet, alltså Intels egna på Intelbaserade system osv. Den bör också vara inställd i AHCI-läge i bios. Men var den i IDE när du installerade windows så måste du följa stegen här: http://bengansblogg.wordpress.com/2010/11/25/sla-till-ahci-mode-for-er-sata-disk-efter-windows-7-installerats/

      • johan skriver:

        Hej!

        Den är i port 1 och achi är aktiverad får en bra skriv&läshastighet på ca 480mb i läs o 180 i skriv så inga fel där.

        Har icke senaste firmware, hur installeras denna måste datorn formateras efter det?
        Hur installerar man bios updateringar fick ner en .rom fil på asus hemsida :(

      • benganrocks skriver:

        -> Har icke senaste firmware, hur installeras denna måste datorn formateras efter det?

        Det är lite olika för olika tillverkare så du får kolla på dess hemsida. Länkar till olika Firmware och guider hittar du här: http://bengansblogg.wordpress.com/2011/09/26/uppdatera-er-ssd-harddisks-firmware-for-battre-prestanda-och-stabilitet/

        -> Hur installerar man bios updateringar fick ner en .rom fil på asus hemsida

        Asus brukar ha en bra inbyggd funktion i bios för uppdatering. Då lägger man bara .rom-filen på en USB-sticka, startar om, går in i bios och kör programmet för uppdatering samt laddar filen ifrån stickan. Sen får man ladda standardinställningar och göra om eventuella inställningar man själv ändrat i bios innan. Står i ditt moderkorts manual hur man gör.

        Men jag skulle absolut börja med Firmwaren på SSDn och se om det hjälper först!

  12. Iman Roshandel skriver:

    Tjena! Måste börja med o säga att jag besöker din blogg dagligen, har nämligen köpt datordelar och byggde klart den idag faktist. Fick mycket hjälp av din blogg :)

    Nu till min fråga då:
    Jag har en SSD med märket: OCZ Vertex 3 MAX IOPS 120GB.
    Den ska vara snabb enligt specifikationerna. Nu gjorde jag AS SSD Benchmark och fick READ: 256 och Write: 281.
    Jag har läst att de ska vara ungefär 500 läs och skriv hastighet juh ?!
    Vad kan va felet tror du? Har hört att man inte ska uppdatera SSD:n när man redan installerat WIndows på de.

    Min andra fråga: Jag har kopplat in min SSD till Intels Sata 6gb/s port precis som du skrev i din blogg att man bör göra. Men när jag gjorde benchmarket så står de:

    iastor – OK (grön text)
    103424 K – OK (grön text)

    det kom alltså inte någon ”msahci – OK”
    Är de något fel här?

    Tacksam för svar! mvh Iman

    • benganrocks skriver:

      Bra att du frågade om detta för jag hade glömt att skriva om just test av Sandforce-baserade diskar!

      Om du läser texten igen under bilden för AS-SSD så tror jag du nu får svar på båda av dina frågor. :)

      Jag gissar att allt är OK, det resultat du får med AS-SSD är alltså sämsta möjliga som man får med data som inte går att komprimera (tex filmer och bilder som redan är komprimerade). Provar du istället med ATTO så bör du få max i närheten av det som tillverkaren anger.

      iastor är också normalt om du installerat Intels RST drivrutin

  13. Marcus skriver:

    Grym blogg Bengan!

    En fråga, när och var sätter jag på AHCI? Jag har klonat Windows till min ssd och tänkte sätta i endast ssd som du skrev om. Därefter tänkte jag ominstallera ssd för att jag hört att prestandas ska höjas gentemot om den bara e klonad… Dessutom så vill jag ha hela min intel 320 ssd 120gb på c och inte uppdelad i c och d…

    Tack på förhand :)

    • benganrocks skriver:

      Du slår till AHCI i moderkortets BIOS (kallas även UEFI på riktigt nya moderkort), helst innan Windows installeras. Hur man gör det är lite olika mellan olika moderkort så det är bäst att läsa dess manual. Oftast får du hålla inne en knapp som tex. Delete när datorn startar för att komma in i BIOS, sen ändrar man där så AHCI är aktiverat för SATA-kontrollern. Sök på ”bios setup” eller liknande på YouTube så hittar du en mängd klipp om det.

      OBS: Om du klonar så bör du kolla så att AHCI är aktiv innan klonen skapas, annars kan du få problem sen. Hur du kan ändra till AHCI efter att windows installerats kan du läsa om här: http://bengansblogg.wordpress.com/2010/11/25/sla-till-ahci-mode-for-er-sata-disk-efter-windows-7-installerats/

      Men har du ändå tänkt att installera om så hade jag helt struntat i kloningen och bara gjort som guiden längst upp på en tom SSD. Du kan ju alltid spara din gamla systemdisk och och ha den som backup att sätta i ifall nåt strular.

  14. Joakim skriver:

    Tänkte bara passa på att tacka för all information du lägger upp på bloggen, hjälper grymt mycket!

  15. René skriver:

    Hej,

    Här värkar det finnas kunniga datafolk! :)
    Jag har en INTEL 320 Serie SSD 120GB SATA II och den hänger sig med jämna mellanrum.
    Har uppdaterat bios och firmware men det hjälper inte.
    Vad kan det vara för fel?
    Har letat hur länge som helst och inte hittat något om detta.
    Datorn är ny sedan december.

    • Tomas skriver:

      Jag har exakt samma problem, köpte en INTEL 320 Serie SSD 120GB SATA II förra veckan, och sedan jag installerat windows 7 64 bit i achi så hänger sig datorn med jämna mellanrum och då måste jag starta om den så fungerar den ett tag.

  16. René skriver:

    …ja och en sak till!
    Ibland så tappar den SSD:n, så när den hänger sig och man startar om datorn så hittar den inte SSD disken :(
    Då får jag pilla lite på satakontakten och så funkar det igen.
    Konstigt….

  17. SSD-Hårddisk skriver:

    Ja, de e helt galet så mycket snabbare SSD-diskarna är! Nuförtiden bootar jag 1 minut och 20 sekunder snabbare än om jag kör med min andra HDD. Kör med bärbar dator, Love it!

  18. Reckless skriver:

    Jag formaterade min dator för några månader sedan och efter jag hade formaterat så försvann min SSD. Hur ska jag göra för att göra den synlig på datorn igen. Jag har AHCI aktiverat i BIOS och jag har updaterat mina drivrutiner. Vet inte vad jag kan göra mera eftersom jag inte är så kunnig inom datorer :/ hjälp mig gärna ifall du vet hur jag kan fixa det

  19. Ping: Installera en SSD i er Laptop och klona all data ifrån gamla hårddisken | Bengans Blogg

  20. LaMa skriver:

    Hej
    Tack för en bra blogg!

    Har ett liknande problem som Hemslöjd hade.
    Jag har precis byggt ihop en ny dator med ASUS z77 bräda och installerat win 7 på en Intel 330 ssd. Fungerar problemfritt tills jag sätter i min gamla hdd (för lagring). Då får jag felmeddelande att hal.dll fattas eller inte finns. Tar jag då bort den gamla hdd igen startar win fint.
    Ssd sitter i port 1 som den ska och hdd satte jag i port 3, SATA körs med AHCI. Allt e uppdaterat. Körde xp innan och jag gjorde lite fel när jag formaterade och ”pationerade” hdd där så det blev en primär och två logiska enheter. Kan det ha betydelse? Kanske finns en MBR på den disken då jag inst xp med den disken i. Nu blev det lite flummigt på slutet men hoppas du förstår vad jag menar. Jag har alltså inte haft något os på denna disken.

    Vad kan man tänkas göra åt detta.

    Tack på förhand
    LaMa

    • benganrocks skriver:

      Saknad Hal.dll är ett vanligt fel att få när något är galet med boot-ordningen.

      Gå in i BIOS och dubbelkolla så att din SSD är först i bootordningen när båda diskarna är inkopplade.

      Annars så gå igenom alla punkterna i det här inlägget: http://pcsupport.about.com/od/errorh/a/hal-dll-missing-windows-7-vista.htm

      Skriv gärna om något av dessa hjälper!

      • LaMa skriver:

        Hej och tack för snabbt svar.

        Allt i BIOS är som det ska. Har till och med tagit bort den gamla disken från boot ordningen. Testat att boota direkt från BIOS på ssd med w7 på. Inget fungerar. Men så tar jag bort disken och vips så startar w7 problemfritt från ssd (jäklar var fort det går också!!!).

        Hittade den sidan du länkat till imorse faktiskt och testade att boota från win 7 skivan för att köra en repair för att komma åt kommandotolken som i punkt 4 (har testat de andra punkterna innan). Då säger den att jag inte har det (w7) os installerat. Den tror med andra ord att jag har xp installerat. Har flyttat disken från port 3 till port 6, utan resultat.

        Kan jag testa att sätta den på en eSATA port och se vad som händer?
        LaMa

      • benganrocks skriver:

        Hmm, knepigt.

        Men måste du ha kvar XP på andra disken? Är du bara ute efter att få över en del filer ifrån den och har sen tänkt att rensa?

        Jag hade nog testat med att sätta disken i ett externt USB-chassi för att komma åt filerna och sen rensa disken helt genom att ta bort partitionerna och börja om. Fördelen med just USB är ju att man då kan plugga i disken efter att systemet startat, kan kanske funka även med eSATA.

        Du kan även prova att ta bort aktiv flaggan ifrån XP-diskens partition med hjälp av Diskpart ifrån Windows skivan: http://www.sevenforums.com/tutorials/119713-diskpart-pc-startup.html

        sen använder du diskpart så här: http://serverfault.com/questions/276076/how-can-i-un-mark-a-partition-as-active

  21. LaMa skriver:

    Xp är jag inte intresserad av, vill bara rädda filerna på disken.

    Aha jag ser att jag har missat att skriva viktig info här. Så här är det. Den gamla disken har aldrig haft något os installerat, den var bara för lagring, xp hade jag på en ännu äldre disk som jag nu ska skrota, den äldsta har aldrig varit i kontakt med det nya systemet. Därför tycker jag att det är så märkligt att den försöker boota därifrån. Men nu ska jag köra ubuntu från cd och se om jag kan kopiera allt från disken till en extern hdd och sedan formatera om disken grundligt. Hoppas bara att jag kan använda den igen. =)
    Annars har jag plan på att köpa denna: http://www.komplett.se/k/ki.aspx?sku=344906

    Återkommer senare.

    • LaMa skriver:

      Körde Ubuntu från skiva och kopierade det jag behövde och sen formaterade jag disken. Det var en master boot record så det var säkert det som strulade. Nu funkar allt och jag har en lagringsdisk igen

      Tack för hjälpen och igen för en bra blogg!

      LaMa

  22. Samuel Andersson skriver:

    Tack för alla tips angående SSDs. Jag klonade igår en Samsung 250gb 7200rpm till en Verbatim 128gb SSD (sata II, helvit förpackning). Allt gick bra och jag monterade den gamla hårddisken som lagringsdisk i DVD-uttaget. Problemet är det egentligen inte blivit någon jätteskillnad i prestanda, WEI gav den 6.5 i betyg. Kan jag göra något för att få det att bli bättre utan att köpa en annan SSD? Någon som har erfarenhet av denna ssd? Datorn är en HP Probook 4320s, 8gb ram, Celeron P4600 2ghz processor, intel hm57 moderkort

  23. Fredrik A skriver:

    Kanonbra info i din blogg! Jag köpte en 64GB OCZ Octane SSD som tyvärr bara fungerade i en dryg vecka men har nu fått pengarna tillbaka och investerade istället i en 120GB Intel 330-serie.

    Jag använde Intels egna migreringsverktyg (gjort av Acronis) som man kan ladda ner från deras hemsida men efteråt när jag, efter ha läst dina tips, kör AS Benchmark märker jag till stor förvåning att Intels egna verktyg inte optimerat datan för att få bra alignment på SSD-disken! Det står bad i benchmarkprogrammet. Känns snopet måste jag säga.

    I den förra mjukvaran jag använde, EaseUS Todo Backup Home (tyvärr bara 15 dagar trial, annars $29) fick man en fråga där man kunde välja att optimera för SSD-disk, då fick man 4kB-storlek på datan istället för tex 110kB som det blev på Inteldisken. Får prova ditt nästa tips och köra Paragon Alignment Tool eller motsvarande och se om det går att rätta till och om jag får bättre prestandavärden i testet sedan. Känns ju ganska viktigt om jag förstått rätt i det jag läst på din blogg.

    • benganrocks skriver:

      Ja, jag är också förvånad! Trodde helt klart att Acronis skulle reagera och fixa till rätt alignment automatiskt. Men det bör vara enkelt fixat med Paragon Alignment Tool, hör gärna av dig hur det funkar.

      Tänk också på att Intels 330 har Sandforce-kontroller och använder komprimering så prova ATTO om du vill mäta max prestanda.

      • Fredrik A skriver:

        Lyckades tyvärr inte få Paragon att funka, den bootade om datorn mitt alignmentprocessen av någon anledning. Hittade dock en friversion av Acronis AlignTool (Intel edition) som klarade biffen. Prestandasiffrorna i AS Benchmark ökade drastiskt, mest på skrivning men även på läsning. Delpoäng ökade från 112 resp 64 till 157 resp. 174. Totalpoäng från 232 till 413! Kapade ytterligare 10 sekunder på windowsstart också så nu känns det som jag (med din hjälp) gjort det jag borde. :o)

Kommentera

Fyll i dina uppgifter nedan eller klicka på en ikon för att logga in:

WordPress.com Logo

Du kommenterar med ditt WordPress.com-konto. Logga ut / Ändra )

Twitter-bild

Du kommenterar med ditt Twitter-konto. Logga ut / Ändra )

Facebook-foto

Du kommenterar med ditt Facebook-konto. Logga ut / Ändra )

Google+ photo

Du kommenterar med ditt Google+-konto. Logga ut / Ändra )

Ansluter till %s